No Worries, DuCal. I appreciate the effort very much.

Dave, my truck has a 1 piece coil set of 3 coils. They were replaced by Old Colt when he did the service on her a year or so ago.

The tech at Meineke told me Saturday that after much hassle and he got a code 41, which is Crank position sensor I believe. He said all kinds of numbers were way off, and that the timing was all fubar. All this is according to his Snap On Modus. Fuel pressure is good. He said he is going to diagnose it further before committing to tearing off the front of the engine, yet again. It has been taken down to the crank sensor 4 times in the last 2 years, most recently about 4 weeks ago before I made the trip down here. The sensor itself was replaced about 2 years ago, when a tech pinched the wires and ruined the sensor putting it back together.

As for OBD, my truck is 1.5, not 2, so it is still fairly primitive.

So I gfuess if the Snap On scanner can read the code, then the ECU must be ok? Or am i mistaken in that as well? LOL

As always gents, thanks ever so much for the replies.

Oh, I almost forgot, can anyone tell me the name of the stealer in TX that everyone orders from?



<img src="/forums/images/graemlins/cheers.gif" alt="" /> <img src="/forums/images/graemlins/patriot.gif" alt="" /> <img src="/forums/images/graemlins/cheers.gif" alt="" /> <img src="/forums/images/graemlins/patriot.gif" alt="" /> <img src="/forums/images/graemlins/cheers.gif" alt="" /> <img src="/forums/images/graemlins/patriot.gif" alt="" />