I haven't posted here in a very long time and to be honest, I had a hard time navigating to post here. Anyway here goes. I purchased new a 2013 4 Runner w/ 4 wheel drive. Shortly after purchase there was a problem and the dealer had to do an alignment to correct. Since then the truck has been great.Every 5000 miles I had the tires rotated by one of two dealerships without any issues. A week ago I was due for my 45,000 mile rotation and visual check of the truck. Two days later I left for a trip on the interstate and noticed the steering wheel began to vibrate between 59 and 70 mph. I ran on different road surfaces thinking that was causing the vibration but there was no difference. 5 days later, (today) I returned to the dealership and explained what was happening. The shop master mechanic went for a road test and said without a doubt it was a balance problem and they would do a rebalance. Then the mechanic who was going to do the work came and said the tires were cupping and that was the cause of the vibration. Now the service manager gets involved and we go for another road test. Now they say it's an alignment problem. So the service manager has the mechanic switch the tires back the way they were before rotation and does a road test by himself. He now claims they did a rebalance of the tires, and an alignment to make it tolerable to drive but I need to be looking for new tires and an alignment after the new tires are installed. I left very disappointed to say the least. The printout they gave me after the inspection and rotation showed the tires had 7/32nd's tread left (out of 10/32nd's new)with no indications of so called cupping in the tires. I even asked for him to show me the cupping and from what he called cupping was near impossible to see. Now my tires are back where they were before and a vibration in the steering wheel still exists (only now it begins about 65mph) where it hadn't before. My first thought was the mechanic over torqued or mistorqued a wheel or two and either bent the wheel(s) or rotor(s) but how can I prove it. They claim with the torque wrench they use they can't over or under torque the lugs.I'm thinking of obtaining a dial indicator and running it on the wheels and rotors to see if they are out. Any other ideas or tests I can do myself would be welcomed. Thanks
TG