Hi everyone!

New user here. I purchased a ’91 Montero (Gen 1) on the spur of the moment a few years ago. I bought her for pennies, but she wasn’t running. I was aware that the timing belt was broke, but not much else. I, quite literally, had no clue what I was getting into. I’ve never really done major auto repair, but I have overhauled plane engines so I have some translatable experience. After parking her for the last two years, I’ve finally decided to dig in during the long, cold winter months up here in Northern MN. Note: this vehicle comes from Georgia and is virtually rust-free.

Vehicle info:
1991 Mitsubishi Montero LS, LWB
3.0L V6, 12 valve, SOHC, 6G72
190k miles

I have been working towards timing belt and water pump replacement over the last few nights (following Haynes manual). Some of the parts had to be removed due to damage. I have removed the following (order of removal may not be exact):
[*]Air intake, cleaner cover, filter
[*]Battery (has not been installed since purchase)
[*]Spark plug wires & plugs
[*]Distributor cap & rotor
[*]Splash pans
[*]Radiator shrouds & radiator
[*]Cooling fan, clutch, & pulley
[*]Drive belts
[*]A/C compressor & bracket (without removing lines)
[*]P/S pump (without removing lines)
[*]Timing belt covers
[*]Water pump (both halves)
[*]Crankshaft bolt & washer
[*]Harmonic balancer, crankshaft flange, crankshaft sprocket, & front crankshaft seal

I am now at the point that I am ready to begin installing the new parts. Pretty much everything mentioned above is being replaced with new parts except for the covers, shrouds, pans…I also intend to replace all fluids in the vehicle. Let's be honest, I don't think a full engine overhaul is out of the question. I'll just be happy if I can get it running for the first time since I've owned it.
So far I’ve learned a lot and have used the manual and this forum to resolve several issues. Before I begin reassembly, there are two issues that I’d like to resolve that I have not been able to find answers to.

1) Vacuum line attached to the bottom of the canister is broken and I don’t know where it is supposed to connect to and what this affects. Conveniently, this is the one vacuum line not fully depicted in the Haynes manual.

2) Ground wire attached to lower LH frame (looks like it may have originally connected to A/C compressor bracket) was found disconnected. I cannot locate where this should properly attach to in the manual.

Here's an image showing these issues:
[img]https://drive.google.com/open?id=11nAln8ZFgZ9963ga8jpq1LpX6mRm4bs4[/img]

Here's an album with some other pictures of the Montero.

Thanks for taking the time to read this post. Any assistance provided would be greatly appreciated. Also open to any comments, recommendations, or criticism you may have.

As the greenhorn that I am, any insight is welcomed.

Cheers,
-Boilermaker4


Boilermaker4

'91 Montero, 3.0L V6 SOHC