Extreme Terrain
4x4Wire Trail Talk Forums: Jeep, Toyota, Mitsubishi, Pajero, Isuzu, Kia, 4WD, 4x4, SUV, Off-Road and OutdoorWire Forums


Search

Recent Posts on TrailTalk
Bump steer problems with ball joint flip/spacers?
by Colombia - 07/04/22 04:17 AM
Gen 1 Trailer Hitch and Owners Manuals
by Kookster97 - 06/28/22 01:34 PM
Gen 2 UCA extended upper ball joints?
by Mudraider - 06/15/22 07:00 PM
suzi the psychic
by rascott - 06/14/22 01:47 AM
Support 4x4Wire
New Topics on TrailTalk
Bump steer problems with ball joint flip/spacers?
by Colombia - 07/04/22 04:17 AM
Gen 1 Trailer Hitch and Owners Manuals
by Kookster97 - 06/17/22 12:37 AM
Gen 2 UCA extended upper ball joints?
by Colombia - 05/24/22 03:28 AM
suzi the psychic
by - 03/26/10 06:59 AM
4x4 Gallery
Photos of rig
Attila
99 Monterrible Sport
Scar the Cylon Raider
Mercenary Sergeant: Code Name "Sapphire"
More News on the 'Wire

4x4Voice
4x4Wire
MUIRNet-News
OutdoorWire
Who's Online Now
0 registered members (), 62 guests, and 5 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums37
Topics138,276
Posts1,081,745
Members15,265
Most Online907
Dec 28th, 2019
Previous Thread
Next Thread
Print Thread
Rate Thread
Page 2 of 3 1 2 3
Re: 95LS 24v 3.0L Sudden Rough Idle? [Re: off-roader] #1060154 05/31/13 11:54 PM
Joined: Oct 2010
Posts: 140
M
MrJeebs Offline OP
Wheeler
Quote
Which brings up some good questions...

Is there visible damage on your ECU? How did you determine it's bad? <img src="/forums/images/graemlins/confused.gif" alt="" />


By the burnt area in the upper right corner as suggested by Ducal. I also found out that my ECU has been worked on before, or is a replacement, as there is all kinds of sloppy yellow writing on it.

Support our sponsors
Re: 95LS 24v 3.0L Sudden Rough Idle? [Re: MrJeebs] #1060155 06/01/13 06:07 AM
Joined: Mar 2003
Posts: 2,324
K
KrzyDav Offline
Body Damage is Cool
*****
like sloppy yellow junk yard paint pin writing?
There's also a place in Houston that's been around a long time,( ?maybe-"ECUforcars"?).
.
Glad you had a good move,,, and esp. that it didn't fry on you when you were halfway to TX.

Last edited by KrzyDav; 06/01/13 06:12 AM.

dave h.
'89 Raider V6 5spd;Aisin Hubs;; Gen2 LS: frt. brakes, rear coils;U.C.arms;R.trailing arms;idler arm; rear LSD axle w.disc brakes ;2 battery system for Dog's fan; relocated ECU; custom bumpers;J.Baker receiver;Conferr roofrack; t-bar crank.
Re: 95LS 24v 3.0L Sudden Rough Idle? [Re: KrzyDav] #1060156 06/02/13 12:13 AM
Joined: Oct 2010
Posts: 140
M
MrJeebs Offline OP
Wheeler
Quote
like sloppy yellow junk yard paint pin writing?
There's also a place in Houston that's been around a long time,( ?maybe-"ECUforcars"?).
.
Glad you had a good move,,, and esp. that it didn't fry on you when you were halfway to TX.


Why yes, sloppy yellow junk yard paint pen writing is exactly what is is <img src="/forums/images/graemlins/barf.gif" alt="" />

Thanks, I appreciate the well wishes. The truck is running really well aside from the idle. I put the ecu back in, as I need the truck to get to work. I did order the one on ebay for $109 shipped. Hope to have it next week. Once I get them swapped, I am going to send the burnt one to the nice gentleman who told me they never go bad.I am very curious to hear what he has to say. He seemed incredibly smart and knowledgeable, Just like the crowd in here <img src="/forums/images/graemlins/kewl.gif" alt="" />

Re: 95LS 24v 3.0L Sudden Rough Idle? [Re: MrJeebs] #1060157 06/02/13 05:00 AM
Joined: Jan 2001
Posts: 13,649
fasteddy Offline
Web Wheeler
*****
Quote
incredibly smart and knowledgeable, Just like the crowd in here



This will get you nowhere. We will still give you crappy advice and a load of sh*t when you do something dumb...


Not responsible for advice not taken...
Re: 95LS 24v 3.0L Sudden Rough Idle? [Re: fasteddy] #1060158 06/02/13 05:11 AM
Joined: Oct 2010
Posts: 140
M
MrJeebs Offline OP
Wheeler
LOL fasteddy, I meant every word! I have yet to receive a single bit of crappy advice from any of the members of this forum. In fact, you yourself would make a good intellectual match for the gentleman I spoke with. He was way above my skill level. I have said it before, and I'll say it again, this is the best online forum I have ever been a part of!

<img src="/forums/images/graemlins/smile.gif" alt="" /> <img src="/forums/images/graemlins/kewl.gif" alt="" /> <img src="/forums/images/graemlins/cheers.gif" alt="" />

Re: 95LS 24v 3.0L Sudden Rough Idle? [Re: MrJeebs] #1060159 06/06/13 04:04 AM
Joined: Oct 2010
Posts: 140
M
MrJeebs Offline OP
Wheeler
Ok, so... Truck continued to run well except for at idle. It seemed to have improved ever so slightly once I fitted the new IAC, but that is likely just wishful thinking on my part. Anyway, I went out to grab a bite to eat last night, and when I left the restaurant, she was idling really rough, as in almost stalling. This was the first time it had been that bad.

But she ran fine as long as it wasn't idling. Got her home and shut her off, and went to bed.

I get up this morning, late for work, and she wont start. She tries to start, but stumbles and sputters and simply will not start.

I get home from work, and figure Ill try her one more time, only this time it doesnt even try to fire. It sounds like shes just spinning the crank, No indicatiojn of the slightest want to fire up. If Had to guess, there was no spark.

So I guess at this point, I am thinking the ecu has totally kicked the bucket. I am still waiting on the replacement I ordered.

It has been a very sad day for me today, as this is the very first time my LS has ever let me down and not started. <img src="/forums/images/graemlins/barf.gif" alt="" />

Do you all agree that it's likely the ecu? I suppose I should be grateful for the week or so I did manage to get out of it once it first exhibited the rough idle.

Re: 95LS 24v 3.0L Sudden Rough Idle? [Re: MrJeebs] #1060160 06/07/13 05:08 AM
Joined: Mar 2003
Posts: 2,324
K
KrzyDav Offline
Body Damage is Cool
*****
on your disributorless 24 valve 3.0 you also have a cam sensor and crank sensor...they'd send a code.
When was the last Timing belt job? This isn't too likely but could belt be off by a tooth from bad belt or tensioner? (24 valve is an "interference engine" so you don't want a belt off the mark).


dave h.
'89 Raider V6 5spd;Aisin Hubs;; Gen2 LS: frt. brakes, rear coils;U.C.arms;R.trailing arms;idler arm; rear LSD axle w.disc brakes ;2 battery system for Dog's fan; relocated ECU; custom bumpers;J.Baker receiver;Conferr roofrack; t-bar crank.
Re: 95LS 24v 3.0L Sudden Rough Idle? [Re: KrzyDav] #1060161 06/07/13 02:24 PM
Joined: Mar 2013
Posts: 43
DuCal Offline
Getting the Wheeling Fever
I got mine new on EBAY for like 200.... I don't even want to know where he got it from for that price. I felt really bad about it for like two mins, then my monty ran perfectly and has never looked back. so I am better now. I'll PM you the link to him, he mite even have another.


Seattle WA... (Everett)
1990 Montero LS OME complete, 2"BL,spray-paint.
1990 Montero LS in the 1st stage of rebuild.
2009 Pilot, Bone stock.
"Let me put on my slightly larger glasses".
Re: 95LS 24v 3.0L Sudden Rough Idle? [Re: DuCal] #1060162 06/07/13 02:29 PM
Joined: Mar 2013
Posts: 43
DuCal Offline
Getting the Wheeling Fever
Ok, sent you a link to the sale, he has a few left as of this second.


Seattle WA... (Everett)
1990 Montero LS OME complete, 2"BL,spray-paint.
1990 Montero LS in the 1st stage of rebuild.
2009 Pilot, Bone stock.
"Let me put on my slightly larger glasses".
Re: 95LS 24v 3.0L Sudden Rough Idle? [Re: KrzyDav] #1060163 06/07/13 11:41 PM
Joined: Oct 2010
Posts: 140
M
MrJeebs Offline OP
Wheeler
Quote
on your disributorless 24 valve 3.0 you also have a cam sensor and crank sensor...they'd send a code.
When was the last Timing belt job? This isn't too likely but could belt be off by a tooth from bad belt or tensioner? (24 valve is an "interference engine" so you don't want a belt off the mark).


The timing belt was done 4 weeks ago or about 1600 miles ago, when the oil pump was replaced due to a severe leak. It is a mitsubishi belt. I opted to replace it when the oil pooled in the cover under the crank pulley and contaminated the belt, which only had about 10,000 miles on it, which was done by Old Colt when he did a full front and top of engine service on her about a year or so ago. He did every pulley, seal, water pump, timing belt and tensioner, plugs, wires... you name it, he did it.

So I got the new used ecu in today, and it did not fix the problem. The truck acts like it wants to start now, but it sputters and pops and will not start. I tried pedal to the floor, light pedal, no pedal, all with no joy. It does make a bit of difference when a small amount of pedal is applied.

I am really distressed at this point. I am in a strange city with no transport. I have called a tow truck with a flatbed to take it to the local Meineke. The Meineke in my old town did the oil pump, so they should be able to share whatever records they have with the shop down here.

DuCal,

The ecus you linked me to are for a different truck, but thank you anyway. I appreciate the effort very much.

Page 2 of 3 1 2 3







4x4Wire Social:

| 4x4Wire on FaceBook |


OutdoorWire, 4x4Wire, JeepWire, TrailTalk, MUIRNet-News, and 4x4Voice are all trademarks and publications of OutdoorWire, Inc. and MUIRNet Consulting.
Copyright (c) 1999-2019 OutdoorWire, Inc and MUIRNet Consulting - All Rights Reserved, no part of this publication may be reproduced in any form without express written permission
You may link freely to this site, but no further use is allowed without the express written permission of the owner of this material.
All corporate trademarks are the property of their respective owners.

Powered by UBB.threads™ PHP Forum Software 7.7.3
(Release build 20190728)
PHP: 7.4.30 Page Time: 0.028s Queries: 16 (0.010s) Memory: 2.9216 MB (Peak: 3.1928 MB) Data Comp: Off Server Time: 2022-07-05 00:51:39 UTC
Valid HTML 5 and Valid CSS