Extreme Terrain
4x4Wire Trail Talk Forums: Jeep, Toyota, Mitsubishi, Pajero, Isuzu, Kia, 4WD, 4x4, SUV, Off-Road and OutdoorWire Forums

Search E-Bay for your parts:
Search Amazon for your parts:

Search

Recent Posts on TrailTalk
Introduction & New Raider
by GrantCee. 11/13/18 11:23 PM
Bushing Removal Trouble
by jimguy11. 11/13/18 03:08 PM
Intermittent No-Start & Stalling
by MarkG. 11/10/18 01:17 AM
New Gen 1 owner need some help
by GrantCee. 11/07/18 12:25 AM
Gen 1 new oil pressure sending unit but faint chec
by Bigshankhank. 11/06/18 02:01 PM
Gas mileage with Weber carb?
by Scrambles. 10/31/18 03:16 PM
3 Rides, change of plans..
by JotaFatstacks. 10/29/18 05:17 PM
Support 4x4Wire
New Topics on TrailTalk
Bushing Removal Trouble
by jimguy11. 11/13/18 03:08 PM
Gas mileage with Weber carb?
by GrantCee. 10/27/18 11:32 PM
New Gen 1 owner need some help
by travish325. 10/24/18 06:21 PM
gen 3 3.8l TPS
by TimVanDyke. 10/24/18 02:41 PM
Hello from Atlanta
by JotaFatstacks. 10/23/18 06:01 PM
4x4 Gallery
Scar the Cylon Raider
Mercenary Sergeant: Code Name "Sapphire"
Flex test after suspension mods
Clearance check!
Testing the new Kenda Klever 31x10.50x15
More News on the 'Wire

4x4Voice
4x4Wire
MUIRNet-News
OutdoorWire
Who's Online Now
0 registered members (), 84 guests, and 4 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums37
Topics137,929
Posts1,079,741
Members14,833
Most Online581
Apr 3rd, 2017
Previous Thread
Next Thread
Print Thread
Rate Thread
Page 2 of 2 1 2
Re: 1991 Montero RS does not stay running [Re: franknspeed] #1104612
10/13/18 04:52 PM
10/13/18 04:52 PM
F
franknspeed  Offline OP
Need a Spot
Joined: Aug 2018
Posts: 7
Michigan
I got one from another 91. Just did a sea foam treatment t and the engine stays running. Which could mean that there was water in the fuel, bad fuel or just all gunked up. Either way, before it died after 2-3 minutes, now it was stable ( also when driving) for over 15 minutes. Still a bit suspicious, though...

Support our sponsors
Re: 1991 Montero RS does not stay running [Re: franknspeed] #1104618
10/15/18 10:58 PM
10/15/18 10:58 PM
F
franknspeed  Offline OP
Need a Spot
Joined: Aug 2018
Posts: 7
Michigan
Update. Been driving around with no issues or warning lights. Lifter tick is also gone. The ‘Fridge ‘ lives on

Page 2 of 2 1 2

Moderated by  Macka, Mudraider, off-roader, PajEvo, rxinhed 

OutdoorWire Websites

OutdoorWire

OutdoorWire

Portal page for OutdoorWire Access and Landuse Central Read More
4x4Voice

4x4Voice

California off road recreation news and information Read More
MUIRNet News

MUIRNet News

News and information about issues affecting outdoor recreation Read More
4x4Wire

4x4Wire

Off road recreation and 4x4 Technical news and information Read More
TrailTalk

TrailTalk

4x4Wire TrailTalk Forums for a variety of 4x4 tech information Read More

4x4Wire Tech Section

Jeep 4x4 Tech

Jeep 4x4 Tech

Jeep Tech from JeepWire - Mods, Maintenance, Tech and more... Read More
Isuzu 4x4 Tech

Isuzu 4x4 Tech

Isuzu Tech from 4x4Wire - Mods, Maintenance, Tech and more... Read More






4x4Wire Social:

| 4x4Wire on FaceBook | Google+4x4Wire on Google+|


OutdoorWire, 4x4Wire, JeepWire, TrailTalk, MUIRNet-News, and 4x4Voice are all trademarks and publications of OutdoorWire, Inc. and MUIRNet Consulting.
Copyright (c) 1999-2017 OutdoorWire, Inc and MUIRNet Consulting - All Rights Reserved, no part of this publication may be reproduced in any form without express written permission
You may link freely to this site, but no further use is allowed without the express written permission of the owner of this material.
All corporate trademarks are the property of their respective owners.

Page Time: 0.011s Queries: 16 (0.005s) Memory: 0.9908 MB (Peak: 1.0587 MB) Zlib disabled. Server Time: 2018-11-14 11:06:41 UTC