Extreme Terrain
4x4Wire Trail Talk Forums: Jeep, Toyota, Mitsubishi, Pajero, Isuzu, Kia, 4WD, 4x4, SUV, Off-Road and OutdoorWire Forums

Search E-Bay for your parts:
Search Amazon for your parts:

Search

Recent Posts on TrailTalk
Introduction & New Raider
by GrantCee. 11/13/18 11:23 PM
Bushing Removal Trouble
by jimguy11. 11/13/18 03:08 PM
Intermittent No-Start & Stalling
by MarkG. 11/10/18 01:17 AM
New Gen 1 owner need some help
by GrantCee. 11/07/18 12:25 AM
Gen 1 new oil pressure sending unit but faint chec
by Bigshankhank. 11/06/18 02:01 PM
Gas mileage with Weber carb?
by Scrambles. 10/31/18 03:16 PM
3 Rides, change of plans..
by JotaFatstacks. 10/29/18 05:17 PM
Support 4x4Wire
New Topics on TrailTalk
Bushing Removal Trouble
by jimguy11. 11/13/18 03:08 PM
Gas mileage with Weber carb?
by GrantCee. 10/27/18 11:32 PM
New Gen 1 owner need some help
by travish325. 10/24/18 06:21 PM
gen 3 3.8l TPS
by TimVanDyke. 10/24/18 02:41 PM
Hello from Atlanta
by JotaFatstacks. 10/23/18 06:01 PM
4x4 Gallery
Scar the Cylon Raider
Mercenary Sergeant: Code Name "Sapphire"
Flex test after suspension mods
Clearance check!
Testing the new Kenda Klever 31x10.50x15
More News on the 'Wire

4x4Voice
4x4Wire
MUIRNet-News
OutdoorWire
Who's Online Now
0 registered members (), 84 guests, and 4 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums37
Topics137,929
Posts1,079,741
Members14,833
Most Online581
Apr 3rd, 2017
Previous Thread
Next Thread
Print Thread
Rate Thread
Intermittent No-Start & Stalling #1104632
10/21/18 10:07 PM
10/21/18 10:07 PM
C
Casey  Offline OP
Need a Spot
Joined: Jul 2018
Posts: 3
Denver, CO
Hi all - I've been lurking in the forum since July when I purchased an '89 Montero LS, 3.0 V6, Auto and excited to be part of Montero group. The truck is mostly original and seems to be in great shape, both cosmetically and mechanically. Some very minor fluid leaks (as to be expected) and a shot passenger window motor seemed to be the biggest issues when I purchased.

Apologies for the length of the post below, but I wanted to give a thorough explanation of what I'm dealing with, in hopes that somebody has had a similar experience or troubleshooting ideas. I have some working knowledge, but am far from an expert. Any and all thoughts/ideas are appreciated. Thank you!

After purchasing the truck and a few days of daily driving without issue, it randomly died while I was leaving my neighborhood. No warning signs, no sputter, just went from running to nothing with all dash & accessory lights coming on. I pulled over and attempted to restart, truck cranked strong but wouldn't fire. Tried every few minutes to get it started, repeatedly same strong crank, but no fire. This continued for ~30 minutes, then without any apparent change/reason, the truck cranked and fired right up as if there were never an issue, and I drove home.

This has been a reoccurring issue for the last few months. 9 out of 10 times that I start the vehicle and drive, I have no issues -- this includes starting from cold, starting from warm, quick trips with frequent starting/stopping/restarting, and long road trips 250+ miles -- when it runs, it seems to run really great.

I haven't been able to pinpoint when/why the no-start and/or stall is occurring, but it has happened approx 20 times and has the same characteristics every time -- either won't start (more frequently occurs when warm vs cold) or it will start normal but die within 10 minutes of driving (I've never had it die once it's been running for more than 10 minutes, but that could just be a coincidence). While driving, it doesn't seem to have a "normal" time to die, meaning it's happened while accelerating, decelerating, while sitting in park, and while sitting at a stop light. After no-start/dying, it has always eventually started, sometimes it takes 5 minutes of periodic cranking, sometimes it takes an hour, but so far it has always started without me "solving" a problem and has no running issues thereafter.

After a searching service manuals and online for answers, I brought it to Mitsu for diagnostic. They were able to recreate the stall once, cleaned some corrosion from a connector and tightened contacts at the power transistor and sent it home. It died the following day so I sent it back, and in the past two weeks they have not been able to recreate the problem (most likely due to a lack of time/effort to try and recreate without a better road map on "when" it is occurring), thus no further diagnostic. I picked up the truck yesterday, ran errands, several start/stops with no issue. Drove to the gym this morning, an hour later it wouldn't start, and 30 minutes after that I was back on the road.

Any thoughts on what this could be? It seems like it must be electrical, but doesn't seem to be a battery, alternator, bad connection, etc. I've seen suggestions to replace the ECU on threads that have similar (but different) symptoms, but hoping somebody might be able to narrow this down before I implement guess and check. Thank you.

Attached Files
Montero.GIF (9 downloads)

Casey
1989 Montero LS, 3.0 V6, 140k miles
Support our sponsors
Re: Intermittent No-Start & Stalling [Re: Casey] #1104635
10/22/18 02:30 AM
10/22/18 02:30 AM
MarkG  Offline
Body Damage is Cool
Joined: Feb 2001
Posts: 2,307
Scaly Mountain, NC, USA *****
The things that come to mind are:
ECU
Power transistor (though I would expect this to fail completely)
Fuel pump or fuel pump relay (would need to check pressure to verify)
Distributor (IIRC there is something different about the 89 vs 90 vs 91 distributors)

There is a 89 Diagnostic Manual available. There are some thing different going into 90. But it might also give you some items to check.


89 6G72 Raider 2dr, ARB Bullbar, Warn Winch, Aisin Hubs, 31x10.5, Cobra CB, Hella Fogs, Bilsteins, PAJERO Badges, Misc AU/EU Parts

98 6G72 Montero Sport, R D Lock, 31x10.5

02 6G74 Montero Limited
Re: Intermittent No-Start & Stalling [Re: Casey] #1104654
10/27/18 09:06 PM
10/27/18 09:06 PM
C
Casey  Offline OP
Need a Spot
Joined: Jul 2018
Posts: 3
Denver, CO
Thanks for the suggestions.

I just popped open the ECU and didn't see any obvious signs that it has gone bad. Connections and pins look good and no signs of any fried spots on the board. I was able to confirm that a "late click" after turning off the engine is coming from the ECU (link to video), can anybody confirm whether this is abnormal? Thanks.

https://youtu.be/tNekFo92CNo

[video:youtube]https://youtu.be/tNekFo92CNo[/video]

Attached Files
ECU Board.GIF (6 downloads)

Casey
1989 Montero LS, 3.0 V6, 140k miles
Re: Intermittent No-Start & Stalling [Re: Casey] #1104674
11/08/18 06:07 PM
11/08/18 06:07 PM
C
Casey  Offline OP
Need a Spot
Joined: Jul 2018
Posts: 3
Denver, CO
I replaced the ECU with a re-manufactured unit from Cardone, but unfortunately the symptoms continue. No issues on Day 1 while running errands and test driving in the neighborhood with frequent stop/starts. Day 2 after ~20-30 minutes of driving the neighborhood with stopping/starting every few minutes, I started up as usual, put into drive and began to pull away, at which point it killed and all dash lights illuminated. I tried to re-start for the next few minutes and it would crank strong, but no fire, same as before. I tried to unplug/replug the ECU, but that didn't result in any changes. Came back an hour later and still wouldn't start. Went back this morning and it started right up, drove 2 mins home, and stopped/started several times in front of the house with no issue.

Both new and old ECU have the same delayed click (as shown in prior video) after disengaging the ignition/starter, so I'm assuming this is normal.


Casey
1989 Montero LS, 3.0 V6, 140k miles
Re: Intermittent No-Start & Stalling [Re: Casey] #1104675
11/08/18 11:37 PM
11/08/18 11:37 PM
G
GrantCee  Offline
Getting the Wheeling Fever
Joined: Nov 2013
Posts: 77
Oregon
A faulty crank position sensor could cause those symptoms.

Ooops, they didn't have a CPS in 1989. My bad. Well, if you had a '96 that's what it could be!

wink

Last edited by GrantCee; 11/08/18 11:56 PM.
Re: Intermittent No-Start & Stalling [Re: Casey] #1104676
11/10/18 01:17 AM
11/10/18 01:17 AM
MarkG  Offline
Body Damage is Cool
Joined: Feb 2001
Posts: 2,307
Scaly Mountain, NC, USA *****
Air / Fuel / Spark

I'm guessing there isn't much wrong with the Air side of the equation.

Fuel -
On a "No Start", do you have much of a raw fuel smell at the tail pipe?
When turning the ignition "on", but before "start", can you hear the fuel pump relay click at the passenger side kick panel? What about the fuel pump?

Spark -
On a "No Start", can you check for a spark at one of the spark plugs?


89 6G72 Raider 2dr, ARB Bullbar, Warn Winch, Aisin Hubs, 31x10.5, Cobra CB, Hella Fogs, Bilsteins, PAJERO Badges, Misc AU/EU Parts

98 6G72 Montero Sport, R D Lock, 31x10.5

02 6G74 Montero Limited

Moderated by  Macka, Mudraider, off-roader, PajEvo, rxinhed 

OutdoorWire Websites

OutdoorWire

OutdoorWire

Portal page for OutdoorWire Access and Landuse Central Read More
4x4Voice

4x4Voice

California off road recreation news and information Read More
MUIRNet News

MUIRNet News

News and information about issues affecting outdoor recreation Read More
4x4Wire

4x4Wire

Off road recreation and 4x4 Technical news and information Read More
TrailTalk

TrailTalk

4x4Wire TrailTalk Forums for a variety of 4x4 tech information Read More

4x4Wire Tech Section

Jeep 4x4 Tech

Jeep 4x4 Tech

Jeep Tech from JeepWire - Mods, Maintenance, Tech and more... Read More
Isuzu 4x4 Tech

Isuzu 4x4 Tech

Isuzu Tech from 4x4Wire - Mods, Maintenance, Tech and more... Read More






4x4Wire Social:

| 4x4Wire on FaceBook | Google+4x4Wire on Google+|


OutdoorWire, 4x4Wire, JeepWire, TrailTalk, MUIRNet-News, and 4x4Voice are all trademarks and publications of OutdoorWire, Inc. and MUIRNet Consulting.
Copyright (c) 1999-2017 OutdoorWire, Inc and MUIRNet Consulting - All Rights Reserved, no part of this publication may be reproduced in any form without express written permission
You may link freely to this site, but no further use is allowed without the express written permission of the owner of this material.
All corporate trademarks are the property of their respective owners.

Page Time: 0.010s Queries: 17 (0.004s) Memory: 1.0209 MB (Peak: 1.1250 MB) Zlib disabled. Server Time: 2018-11-14 11:33:09 UTC