Extreme Terrain
4x4Wire Trail Talk Forums: Jeep, Toyota, Mitsubishi, Pajero, Isuzu, Kia, 4WD, 4x4, SUV, Off-Road and OutdoorWire Forums


Search

Recent Posts on TrailTalk
Help me troubleshoot my Gen1 A/C problem
by ProjectManDan - 09/24/20 03:03 AM
Flying 1000mi to buy a 97 Montero SR sight unseen
by Macdrew77 - 09/23/20 10:18 PM
I am closing the Montero Ranch for good.
by rxinhed - 09/23/20 03:47 AM
GEN1 AT AW372 Manual Shaft Seal Replacement
by rxinhed - 09/22/20 04:04 PM
Raider 2.6 flywheel/starter question
by rxinhed - 09/22/20 03:49 PM
Introduction - B-Line Performance
by B_Line - 09/21/20 04:08 PM
Support 4x4Wire
New Topics on TrailTalk
I am closing the Montero Ranch for good.
by rxinhed - 09/23/20 03:47 AM
Flying 1000mi to buy a 97 Montero SR sight unseen
by Macdrew77 - 09/19/20 04:18 AM
Raider 2.6 flywheel/starter question
by nonkjo - 09/17/20 02:28 PM
Introduction - B-Line Performance
by B_Line - 09/16/20 09:53 PM
Help me troubleshoot my Gen1 A/C problem
by 81for91 - 09/16/20 05:18 AM
4x4 Gallery
Photos of rig
Attila
99 Monterrible Sport
Scar the Cylon Raider
Mercenary Sergeant: Code Name "Sapphire"
More News on the 'Wire

4x4Voice
4x4Wire
MUIRNet-News
OutdoorWire
Who's Online Now
0 registered members (), 100 guests, and 5 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums37
Topics138,139
Posts1,080,772
Members15,096
Most Online907
Dec 28th, 2019
Previous Thread
Next Thread
Print Thread
Rate Thread
Hello! New member 87 Raider with questions! #1105185 08/19/19 03:54 AM
Joined: Jul 2019
Posts: 1
C
Chrystine Offline OP
Need a Spot
Hi everyone! I am new to the Raider world and I am in love with this little 4x4! I have some questions and need some help! It’s an 87, 5 speed, 2.6L I bought this 3 hrs away from home. The guy said he rebuilt it with new head from a montero, pistons, rings, oil pump, timing chain, & fuel pump. So it test drove ok and I snagged it for 1500. Drove home and watched gauges like a hawk. Did ok but two hours in oil pressure drops and it died on frwy. Well I live in the desert. I think it was 110 or more that day. I didn’t even bother trying to start it, I just towed it. Next day it starts up and the motor shakes bad. I take it to mechanic and he claims it’s ok. So I take it home and it dies again. So....I change the oil, new filter ( the one on it was wrong and too small) I change the oil pressure switch. New k&n air filter and fuel filter (which wasn’t changed yet the pump was?). And now the oil pressure was back up and holding but it still shook like crazy. So now I change the plugs, wires, rotor and cap. Now it’s not shaking! Sounds sooo much quieter. BUT....it now knocks loudly on acceleration. It runs ok and doesn’t seem to want to die. I’ve on,y driven around the block keeping it low just to be sure it won’t stall. So I’m not sure what it could be. The egr light was on when I got it if that matters. Any help in right direction is appreciated.
[Linked Image from live.staticflickr.com]Untitled by Chrystine Gimeno, on Flickr

Last edited by Chrystine; 08/19/19 03:58 AM.
Support our sponsors
Re: Hello! New member 87 Raider with questions! [Re: Chrystine] #1105189 08/20/19 04:38 PM
Joined: Feb 2005
Posts: 7,306
rxinhed Offline
Trail Leader
*****
Reset the light by moving the slide switch behind the speedo. Check your timing. Check the chain tension.

Download a copy of the factory service manual (FSM) at mitsubishilinks.com and don't forget that you are welcome to ask questions.

Lastly, but firstly, welcome to the Wire! smile

Russell

Re: Hello! New member 87 Raider with questions! [Re: Chrystine] #1105197 08/28/19 12:58 AM
Joined: Oct 2018
Posts: 79
B
Bigshankhank Offline
Getting the Wheeling Fever
Welcome, nice looking rig! I wish I could help, mine has the V6 but I’m sure you’ll find the help you need.

Question for the forum; is the arched scratch on the passenger side of the windshield a factory installed thing? Because mine has it, and the one in my local JY has it and now I see yours has it too!


1989 Dodge Raider V6
2001 Jeep Wrangler 4.0L
2008 Toyota 4-Runner SR5 4wd
Re: Hello! New member 87 Raider with questions! [Re: Chrystine] #1105201 08/31/19 07:03 PM
Joined: Feb 2005
Posts: 7,306
rxinhed Offline
Trail Leader
*****
That scratch comes from operating the wiper system without a wiper or with a failed wiper. This is not a factory thing.








4x4Wire Social:

| 4x4Wire on FaceBook |


OutdoorWire, 4x4Wire, JeepWire, TrailTalk, MUIRNet-News, and 4x4Voice are all trademarks and publications of OutdoorWire, Inc. and MUIRNet Consulting.
Copyright (c) 1999-2019 OutdoorWire, Inc and MUIRNet Consulting - All Rights Reserved, no part of this publication may be reproduced in any form without express written permission
You may link freely to this site, but no further use is allowed without the express written permission of the owner of this material.
All corporate trademarks are the property of their respective owners.

Powered by UBB.threads™ PHP Forum Software 7.7.3
(Release build 20190728)
PHP: 7.2.33 Page Time: 0.026s Queries: 15 (0.007s) Memory: 2.8397 MB (Peak: 3.1632 MB) Data Comp: Off Server Time: 2020-09-25 04:13:36 UTC
Valid HTML 5 and Valid CSS