Extreme Terrain
4x4Wire Trail Talk Forums: Jeep, Toyota, Mitsubishi, Pajero, Isuzu, Kia, 4WD, 4x4, SUV, Off-Road and OutdoorWire Forums


Search

Recent Posts on TrailTalk
NP 235 T-case swap in Raider. ?
by rxinhed - 10/25/20 07:43 PM
Sway Bar delete.. ???
by rxinhed - 10/25/20 07:40 PM
Gen I to Gen II compatability thread
by Trailmonkey - 10/25/20 01:59 AM
Flying 1000mi to buy a 97 Montero SR sight unseen
by dripdrip - 10/24/20 04:59 PM
Hazard Switch gone bad, no lights.
by Trailmonkey - 10/23/20 11:36 PM
Gen 1 rear locker ?
by MontyMcV - 10/21/20 04:01 PM
help me build a bulletproof 2.6
by 87CanadianRaider - 10/21/20 01:57 AM
Support 4x4Wire
New Topics on TrailTalk
Sway Bar delete.. ???
by Trailmonkey - 10/25/20 02:37 AM
Hazard Switch gone bad, no lights.
by Trailmonkey - 10/22/20 07:37 PM
Mass Airflow unit questions.
by Trailmonkey - 10/14/20 12:15 AM
Relay under console !
by Trailmonkey - 10/08/20 06:35 PM
New 91 montero LWB owner and a few questions.
by iateatoad - 10/05/20 02:59 PM
Looking so see what my set up is worth
by Fretwellj - 09/29/20 03:07 AM
4x4 Gallery
Photos of rig
Attila
99 Monterrible Sport
Scar the Cylon Raider
Mercenary Sergeant: Code Name "Sapphire"
More News on the 'Wire

4x4Voice
4x4Wire
MUIRNet-News
OutdoorWire
Who's Online Now
0 registered members (), 124 guests, and 6 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums37
Topics138,146
Posts1,080,836
Members15,113
Most Online907
Dec 28th, 2019
Previous Thread
Next Thread
Print Thread
Rate Thread
kia codes 303 and 422 #894299 07/06/08 05:31 PM
Joined: Nov 2005
Posts: 51
I
itswrongway Offline OP
Getting the Wheeling Fever
help, P0303 misfire cyl.3 I checked plug,wire. and coil everything seems ok. volts from coil match the other one. P0422 cat. under threshold bank 1. what do I look for on this one ? I switched # 3 and # 2 plugs and the coils. engine was ok til it reached runing temp. then it started to run rough again. I cleared the codes and waitting to see what pops up since it is still running bad. some info. on what to look for or do would be nice.( when I said I switched the coils I just switched front to rear and rear to front.)

Support our sponsors
Re: kia codes 303 and 422 [Re: itswrongway] #894300 07/07/08 04:19 AM
Joined: Aug 2006
Posts: 894
bombardj1 Offline
Rock Warrior
when u pulled the plugs what did they look like ? make sure u have a good connection with the coil harness. did u pull all the plugs and look at each ? make sure u use anit-seize compound on the plugs u might already but I am just making sure u do my friend <img src="/forums/images/graemlins/patriot.gif" alt="" />, as for the 0422 don't know right off the top of my head other then the 02 sensor I would disconnct it, clean the connector then reconnect it. ( any good electric connection spray should work )

Re: kia codes 303 and 422 [Re: itswrongway] #894301 07/07/08 04:33 AM
Joined: Aug 2006
Posts: 894
bombardj1 Offline
Rock Warrior
1 thing it's possible because of the miss firing of #3 plug the raw gas might have fouled up the sensor or Cat, the other guys here would know more on that

Re: kia codes 303 and 422 [Re: itswrongway] #894302 07/09/08 06:43 PM
Joined: Apr 2002
Posts: 1,221
logansportage Offline
Body Damage is Cool
My o2 sensor sends this code about 2 times per year. Usually when a little more water gets in the gas. Try a fuel injector cleaner like the one from Lucas Oil. That usually resolves it for me.

Logansportage <img src="/forums/images/graemlins/patriot.gif" alt="" />


White 1998 4 door KIA Sportage 4x4 w/Eibach 2.5 spring lift and TJ rear coils, 4crawler 1.5 body lift, Monroe Sensa.trac shocks, Bosch 4+ plugs, Eaton LSD, 31x10.5x15 BFG KM tires, 2.5 cat back exhaust w/SpinTech muffler
Re: kia codes 303 and 422 [Re: logansportage] #894303 07/09/08 07:28 PM
Joined: Nov 2005
Posts: 51
I
itswrongway Offline OP
Getting the Wheeling Fever
sorry it took so long to get back on the web. this sat. I am going to check the fuel injector for # 3 it might be bad. I have 2 02 sensors 1 before and 1 after the cat that no longer is there and hasn't been for 2 yrs. the code 422 dosen't show up as a o2 sensor so you all have me puzzeled. maybe I need to get back into the ecm again. thanks any more suggestions would help.

Re: kia codes 303 and 422 [Re: itswrongway] #894304 07/09/08 10:28 PM
Joined: Mar 2002
Posts: 4,497
Axe Man Offline
Kia Moderator Emeritus
Quote
sorry it took so long to get back on the web. this sat. I am going to check the fuel injector for # 3 it might be bad. I have 2 02 sensors 1 before and 1 after the cat that no longer is there and hasn't been for 2 yrs. the code 422 dosen't show up as a o2 sensor so you all have me puzzeled. maybe I need to get back into the ecm again. thanks any more suggestions would help.


P0422 is a cat efficiency code and it is determined by reading the REAR O2 sensor. Since you said there isn't one there that would explain that code. I am very surprized that you are not throwing other rear O2 codes.


1998 Sportage - Gone.
2004 Honda Civic Coupe.
2007 Suzuki Grand Vitara - She got it.
Re: kia codes 303 and 422 [Re: Axe Man] #894305 07/12/08 04:27 PM
Joined: Nov 2005
Posts: 51
I
itswrongway Offline OP
Getting the Wheeling Fever
I need help. I replaced the plugs anyway and check the plug wires with a volt meter and they seem to be ok but I am replaceing them today also. I pulled the fuel injectors friday night and they seem to be working to the extent that when power is put to them they click open and close, as for the spray pattern I don't know.I still have a misfire on # 3 cyl. I don't want to put it in the shop because it'll cost me a arm and leg. if anyone could give me some idea what to look for. THANKS

Re: kia codes 303 and 422 [Re: itswrongway] #894306 07/12/08 04:33 PM
Joined: Nov 2005
Posts: 51
I
itswrongway Offline OP
Getting the Wheeling Fever
AXE MAM, ya I haven't had a cat on the kia for 2 years now.haven't had any problems with it showing any codes until now. my cat blew out one day and I didn't have $384 for a new one so I left off.

Re: kia codes 303 and 422 [Re: itswrongway] #894307 07/13/08 03:02 PM
Joined: Nov 2005
Posts: 51
I
itswrongway Offline OP
Getting the Wheeling Fever
yea, I fixed the problem with the misfire on # 3 cyl.turned out to be the fuel injector after all. thanks for your help guys.


Moderated by  4x4Wire, Axe Man, DamKia, Mike Bondi 







4x4Wire Social:

| 4x4Wire on FaceBook |


OutdoorWire, 4x4Wire, JeepWire, TrailTalk, MUIRNet-News, and 4x4Voice are all trademarks and publications of OutdoorWire, Inc. and MUIRNet Consulting.
Copyright (c) 1999-2019 OutdoorWire, Inc and MUIRNet Consulting - All Rights Reserved, no part of this publication may be reproduced in any form without express written permission
You may link freely to this site, but no further use is allowed without the express written permission of the owner of this material.
All corporate trademarks are the property of their respective owners.

Powered by UBB.threads™ PHP Forum Software 7.7.3
(Release build 20190728)
PHP: 7.2.34 Page Time: 0.029s Queries: 15 (0.008s) Memory: 2.8627 MB (Peak: 3.1634 MB) Data Comp: Off Server Time: 2020-10-26 04:17:09 UTC
Valid HTML 5 and Valid CSS