4x4Wire TrailTalk

New forum ?

Posted By: Trailmonkey

New forum ? - 08/16/21 04:32 PM

Any suggestions on a more active Montero forum ?
Posted By: Mudraider

Re: New forum ? - 08/18/21 01:58 PM

You just don't get it. Forums are pretty much dead. All the new social media platforms make it so easy to download pictures and such. Plus they are right there on your phone. Regardless of how big a black hole for information they are. I hate Facebook, even though i run one of the biggest Mitsubishi pages on there.. It's a necessary evil. I'd druther stuff was on here, because you can't hardly find anything over a couple of years old on Facebook.
Posted By: Mudraider

Re: New forum ? - 08/18/21 02:07 PM

Don't shoot the messenger, just stating the facts. Facebook has been set up with a 3rd grade mentality so it's easy to put out information, whether you should be or not. Some things people let out on social media is mindboggling.
Posted By: Trailmonkey

Re: New forum ? - 08/18/21 04:23 PM

Yeah this place is about as dead as my ex's sex drive., I know you make fun of anti facebookers, but I just didn't even want my phone linked to that place.
I do get it, but wondered if there was a better place. I like this one and the people, just it's a ghost town.

Send me a link to the one you are on.
Posted By: OldColt

Re: New forum ? - 08/18/21 05:41 PM

For some of us Farcebook sucks. It really does. Too many ExSpurts who have never even changed a wheel or any part with anything other that they carry in their wallet.
You can't call me an anti Farcebooker since I host 3 different, well I was going to call them forums, don't really know what they are.

Farcebook is the only place where I have answered a question, with description and been told I do not know what I am talking about. This is by someone who can not change a wiper blade, but has thousands of posts so they are an ExSpurt.

Yes unfortunately this once great place is dead, heck I do not see that any Toyota guys have even been on the site, not much more from the Jeep crowd.
It's to bad the Mitsus are not moved up to the top, maybe they would catch someone's eye.

And I do not even have a phone or tablet that can go there, we do not have a lick of cell service where I live.
Posted By: rxinhed

Re: New forum ? - 08/19/21 03:38 AM

Sorry, TM. Of all the Mitsu boards, the OG crew comes from here. There is a little bit of tech on Expedition Portal...but the theme there, or course, is camping.
Posted By: Trailmonkey

Re: New forum ? - 08/19/21 01:36 PM

Originally Posted by rxinhed
Sorry, TM. Of all the Mitsu boards, the OG crew comes from here. There is a little bit of tech on Expedition Portal...but the theme there, or course, is camping.


Yeah anytime I try and do some research most say 4x4wire is the place., that's what brought me here in the first place..

But I need to get my truck right, no one around my local is of any help, seems I will go to FB long enough to get it. Really could use someone here in my town to help diagnose the issues, me being in a wheelchair I can only do so much and along with my injuries I got some brain injury, so my mechanicing is fine but the chasing down some of these issues just has me stumped, to the point I've wanted to sell it, but who would want a truck that won't start, doesn't run right, even my headlights only have low beams. Lol
I really need to explain the problem and have a group say, oh I know what that is..
Posted By: Mudraider

Re: New forum ? - 08/19/21 07:23 PM

Originally Posted by Trailmonkey
Originally Posted by rxinhed
Sorry, TM. Of all the Mitsu boards, the OG crew comes from here. There is a little bit of tech on Expedition Portal...but the theme there, or course, is camping.


Yeah anytime I try and do some research most say 4x4wire is the place., that's what brought me here in the first place..

But I need to get my truck right, no one around my local is of any help, seems I will go to FB long enough to get it. Really could use someone here in my town to help diagnose the issues, me being in a wheelchair I can only do so much and along with my injuries I got some brain injury, so my mechanicing is fine but the chasing down some of these issues just has me stumped, to the point I've wanted to sell it, but who would want a truck that won't start, doesn't run right, even my headlights only have low beams. Lol
I really need to explain the problem and have a group say, oh I know what that is..


Your in Ocala, we have 4 or 5 guys on FM4X4 that live there. I try and get folks to come here. There's more experience here on this post that at any one time over on the fb pages. There's a mechanic in Ocala a couple of the guys use, I'll try and get them on here.
Posted By: Trailmonkey

Re: New forum ? - 08/19/21 08:07 PM

Actually I'm in Monticello, 30 miles east of Tallahassee.
Posted By: Mudraider

Re: New forum ? - 08/19/21 08:50 PM

I put the word out, hopefully they can hook you up with Info and help.
Posted By: montyhaul

Re: New forum ? - 08/19/21 10:18 PM

Frank put out the word on Facebook - Bill here- I'm in Hawthorne, only marginally closer than Ocala- pretty much all activity is on Facebook- though if you hate FB or get banned we also have a group on mewe. What do you need help with Trailmonkey? BTW- my first activity here since 2019.
Posted By: 4x4Wire

Re: New forum ? - 08/20/21 12:14 AM

Thank-you for your continued support of the 4x4Wire TrailTalk Forums.

As noted, social media are the current trend setters for many things. Social media is noted for current discussion and lacking historical reference.

Hence, traditional forums sites still function as the historical repository of information.

On January 1, 2022, 4x4wire.com will celebrate 22 years as a website. The TrailTalk Forums went life a few months later. Much has changed over the past 20 plus years.

4x4Wire is still in private control, not beholding to some corporate entity.

As requested, the Mitsubishi Forums are now at the top of the list, the first forum you see when the site loads.
Posted By: Trailmonkey

Re: New forum ? - 08/20/21 02:36 AM

Originally Posted by 4x4Wire
Thank-you for your continued support of the 4x4Wire TrailTalk Forums.

As noted, social media are the current trend setters for many things. Social media is noted for current discussion and lacking historical reference.

Hence, traditional forums sites still function as the historical repository of information.

On January 1, 2022, 4x4wire.com will celebrate 22 years as a website. The TrailTalk Forums went life a few months later. Much has changed over the past 20 plus years.

4x4Wire is still in private control, not beholding to some corporate entity.

As requested, the Mitsubishi Forums are now at the top of the list, the first forum you see when the site loads.




No problem on support here, I prefer this over the FB stuff. But they do have the numbers.
Posted By: Trailmonkey

Re: New forum ? - 08/20/21 03:02 AM

Originally Posted by montyhaul
Frank put out the word on Facebook - Bill here- I'm in Hawthorne, only marginally closer than Ocala- pretty much all activity is on Facebook- though if you hate FB or get banned we also have a group on mewe. What do you need help with Trailmonkey? BTW- my first activity here since 2019.


Thank you, starter not engaging is my need to fix right now, new battery, new solenoid, took apart and cleaned starter, all connection are good, solenoid hits hard, but seems to not mesh with the flexplate teeth and turn over, turn the crank pully a micro amount and it pops right off. I will take the starter back off and inspect the flexplate.

Then the random running bad, my ignition took a crap on me a while back, even the ecu, not run right since, replaced.. ecu, maf unit, coil, igniter, distributor. Been thinking fuel system but starting to think its timing going wacky on me, that I'm afraid would be the ecu.
It's acting like weak fuel, or bad timing, runs fine then all of a sudden it studders and boggs, more throttle just adds spitting and sputtering for a bit and instantly clears up and takes off, here lately even then it still isn't 100% .
Best I see all connections are good, . Will put timing light on it and wait for it to mess up and see if it's the timing. After that I don't see how but could be a relay ? Something I'm missing ?
Just it ran great till the burn up of parts. Last codes I got was ... crank sensor, fuel pump and o2 sensor.
O2 is from the fuel pump not working right, pump not working right from the crank sensor (distributor) not working right, but if the ecu is flawed wouldn't that do it all ? New distributor didn't change a thing.
Fuel pump is working but not sure 100% to its peak..
Got a new fuel pressure regulator I'll put on here shortly.
Could it be something in the throttle body ? Throttle position sensor ?
Posted By: OldColt

Re: New forum ? - 08/20/21 08:42 AM

Thank you John,
I did not expect to be listened to when I spoke. Guess I have been giving in to the they way this world is declining with little interest in maintaining history. And this site has retained it's history while so many others have failed.
Posted By: Trailmonkey

Re: New forum ? - 08/29/21 06:58 PM

Well this place has all but died it seems, was starting to hope more long term members would come back around.
Posted By: OldColt

Re: New forum ? - 08/29/21 10:41 PM

I cycle through no less than eight forums twice a day and answer what I can. Of those eight one is busy on a daily basis and two have multiple postings a few times a week. It is sad to not see the elders around, I have barely even been here 15 years yet.
A couple of the elders you see over on Farcebook and a few are, well sad to say, gone.
Posted By: MarkG

Re: New forum ? - 08/30/21 02:10 AM

I wander by a couple of times every week. I'll jump in to a discussion if I can offer anything useful.
Posted By: JAVYPRO

Re: New forum ? - 09/27/21 09:57 PM

Hello gang, I will know when I post this. LOL. I have been a 4x4wire member for gosh so many years and still live it. It is my main source for knowledge with my 2 Gen II SWB and LWB and my Gen III still when I have joined the dark side. I got me a Jeep Gladiator, nahhhh I love Jeeps too, comes in the family.LOL

Hey John I still have my 4x4wire Jean shirt, I love it.LOL

Nothing like saying hi to the gang.
Ja y
Posted By: Trailmonkey

Re: New forum ? - 10/03/21 06:59 PM

If people would actually post more it would be nice.
© 2021 4x4Wire TrailTalk