4x4Wire TrailTalk

Missng Parts! Help Identify

Posted By: topher

Missng Parts! Help Identify - 06/23/10 09:45 AM

Hi Folks! I just got a 2nd hand 96' Sporty 4wd last month. Everything seems to be ok until I notice a huge chunk in the engine is missing. Please help out figure out whats missing so I can have it installed. as for the engine, it runs smoothly, no issues with uphill, infact the engine is quite strong. But... the rpm does go up (rarely) without pressing the gas pedal. It goes from 1000 to 3000 even higher if I dont shut the engine down.

1. What is missing? Canister evap? what else?

2. What happens if I dont install them? the engine seems to be ok as of now.

3. Does anyone of you tried to take those things off?
[Linked Image] [Linked Image]
Posted By: DennisThompson

Re: Missng Parts! Help Identify - 06/29/10 01:06 AM

I would like to help you but your pics didn't show up on my computer. Does your RPMs go up sitting still or is it when you are rolling at idle. My RPMs will go up as I am rolling down the driveway but goes right back to normal when I stop.

Dennis
Posted By: topher

Re: Missng Parts! Help Identify - 07/02/10 12:12 PM

Hi! I'm sorry if it took me a while to get back. I had so much problem with the car after posting this. So far i've changed the brake master assembly and the throttle position sensor and wiring through the ECU. I guess that solved the RPM issue. But still missing some parts there. I'll post the pics (correctly i hope this time).

[Linked Image]

[Linked Image]
Posted By: Anonymous

Re: Missng Parts! Help Identify - 07/03/10 05:22 AM

I would imagine from this photo you do not have A/C.
That is where my A/C stuff is at...not that it does anything.....
Posted By: jaboo5322

Re: Missng Parts! Help Identify - 07/03/10 03:53 PM

Fuel vapor canister, and purge soelenoids. If it was on that year, that's part of what's missing. My tank rotted out and i put a fuel cell in the back, so i removed mine and everything was fine. But i don't have e-check.

[Linked Image]

Posted By: DennisThompson

Re: Missng Parts! Help Identify - 07/03/10 09:28 PM

Your 96 probably looks more like my 95,

[Linked Image]

Hope that helps. Dennis
Posted By: topher

Re: Missng Parts! Help Identify - 07/04/10 02:16 AM

Quote
Your 96 probably looks more like my 95,

[Linked Image]

Hope that helps. Dennis


I would say this is the perfect part that's missing. but what does it do? or what will happen if i dont have this part for a long period of time?
Posted By: topher

Re: Missng Parts! Help Identify - 07/04/10 02:22 AM

[quote]Fuel vapor canister, and purge soelenoids. If it was on that year, that's part of what's missing. My tank rotted out and i put a fuel cell in the back, so i removed mine and everything was fine. But i don't have e-check.


How long have you had this removed? did you notice any difference?

Thanks for all your replies! I find this forum very active and people are more knowledgable especially with 4x4s!
Posted By: DennisThompson

Re: Missng Parts! Help Identify - 07/05/10 07:14 PM

I'm pretty sure they are for emisions, it will probably run ok without them you just may not pass a smog test.

Dennis
Posted By: Everet

Re: Missng Parts! Help Identify - 07/05/10 07:24 PM

Note that he is also missing the EGR system...as tho it were from the factory that way.

Everet <img src="/forums/images/graemlins/patriot.gif" alt="" /> <img src="/forums/images/graemlins/cheers.gif" alt="" /> <img src="/forums/images/graemlins/kewl.gif" alt="" />
Posted By: jaboo5322

Re: Missng Parts! Help Identify - 07/06/10 12:47 AM

From those pics, it looks like nothing really is missing. Is there a fitting on the passenger side of the itake manifold? I don't see alot of the fitting and such that mine has. Good luck.
Posted By: topher

Re: Missng Parts! Help Identify - 07/06/10 01:40 PM

Quote
I'm pretty sure they are for emisions, it will probably run ok without them you just may not pass a smog test.

Dennis


I really thought of that...and worried that i wont pass the test this august on car registration day. i'll try to look around and see if i can have one set up. Thanks dennis!
Posted By: Sportege_Panicmech

Re: Missng Parts! Help Identify - 07/08/10 07:04 AM

There's two different EVAP systems available to 1st gen sportages.. the big one is the main guy, the little one is possitioned infront of the washer tank I believe and that may be what you have.
That is the location of where the big guy would be, your EVAP Charcoal canister. It's emissions related but not exhaust emissions. You MAY actualy be able to PASS emissions without it.. I don't know if they visually inspect the canister, but if your missing it and your check engine light is on, they'll scan the code most likely and they'll find out.
Primarily they 'sniff' your exhaust with a machine i believe. if your gasses: 02, CO2, NOX, or (i forget this one) are out of wack, then they fail you.. but the EVAP system is not direct exaust emission related.. But i don't know if they also cover EVAP systems. (input anyone?)
Ya know how an old classic will sometimes smell like gas if parked in a poor ventillated garage even when it's just parked.. it's because their gas tanks ventilate to keep the tank from naturaly building pressure from the fuel vapors.. well, those vapors are harmfull and cause cancer only in the state of california (lol). But you can't just seal the tanks. So they still today vent the tanks, but they use charcoal as a filter to catch the harmful vapors and allow the air to pass.. then when you start your car, the vapors are sucked into your engine via a vacuum line so that it's not wasted or building up. when the car is running, the vent system is closed to allow the tank to pressurize. there are electronic valves (purge and vent) that control when the tank can vent or not vent and pressure sensors to check if your system is working right.. therefore your Check engine light may be on if it's supposed to have it. Hope that makes sense. I'm burnt out. long hot day. typcally though, a failed EVAP system doens't alter performance or economy.
Posted By: topher

Re: Missng Parts! Help Identify - 07/10/10 02:06 PM

Thank you for the detailed explanation. Though im not noticing any setbacks in terms of engine performance, i do smell a little carbon/fuel but tolerable. As for the engine light, that's a negative. No check engine light. Im guessing it has been disconnected to the ECU? Or to something that would make it lit.
Posted By: Sportege_Panicmech

Re: Missng Parts! Help Identify - 07/11/10 08:20 AM

Weird. Maybe someone has done a mod we aren't aware of here. Or.. maybe your's had a unique design of a rarity. In either case the C.E.L. isn't on makes me wonder if the bulb burnt out and is actually on. or if the bulb is intact and it really is off. If it's really off then i'd just go about my merry way with it.. have you verified the C.E.L. comes on when you first turn the key.. it should momentarily along with every other dash warning light upon start up. if not, the bulb is likely burnt out. <img src="/forums/images/graemlins/cyclops.gif" alt="" />
Posted By: topher

Re: Missng Parts! Help Identify - 07/11/10 12:42 PM

Quote
Weird. Maybe someone has done a mod we aren't aware of here. Or.. maybe your's had a unique design of a rarity. In either case the C.E.L. isn't on makes me wonder if the bulb burnt out and is actually on. or if the bulb is intact and it really is off. If it's really off then i'd just go about my merry way with it.. have you verified the C.E.L. comes on when you first turn the key.. it should momentarily along with every other dash warning light upon start up. if not, the bulb is likely burnt out. <img src="/forums/images/graemlins/cyclops.gif" alt="" />


the light is okay. it does exactly like you mentioned. i believe its MODed already. I hope its not a bad thing, but i will have this check once and for all (lol). as for the MODs i've noticed, the throttle position sensor and MASS sensors are replaced by a BOSCH sports sensors. God knows what else were replaced, but they did a good job.
© 2022 4x4Wire TrailTalk