4x4Wire TrailTalk

i think.. it's the rings...

Posted By: TheGoat

i think.. it's the rings... - 11/01/12 09:32 PM

so a while ago, i'm sure some of you know that i had to replace my rear main twice cause it was pushed out. the other day i notice i'm leakin oil. i pop the hood and see oil EVERYWHERE.. i then look at the fill cap and it's actually seeping out of there. i release the cap and it's under a huge amount of pressure.. pretty sure it's the rings.. <img src="/forums/images/graemlins/frown.gif" alt="" /> eh.. i'll keep driving it for a while. i put in some "restore" engine restorer today.. hahahaa. snake oil. we'll see if it does anything. i'm going to guess not.. still didn't stop me from cleaning it and waxing it. now, next time it gets dirty, it should be easier to clean..

so, it looks like a full rebuild is in order in the near future. just have to make it through winter..
Posted By: Dryver

Re: i think.. it's the rings... - 11/02/12 12:08 PM

How's your PCV system?
Posted By: Peabody

Re: i think.. it's the rings... - 11/02/12 05:56 PM

I second that notion. The PCV valve (Positive Crankcase Ventilation) allows blow-by gasses that enter the crankcase to vent out, while sealing the crankcase when it holds a vacuum. A vacuum is normal and desired - that's what drives all of the vacuum-bases systems on the vehicle. If your PCV valve is plugged, pressure will build and will blow oil out of any feasible point and may blow seals and/or gaskets. A bad PCV valve may be the problem. Or it could exacerbate another problem, such as worn rings. The valve is only a few bucks to replace and it's easy to do. Blown seals, like your rear main, can be a real pain in the <img src="/forums/images/graemlins/butwiggle.gif" alt="" />, as you well-know. Check your PCV valve. If it doesn't rattle, get a new one.

<img src="/forums/images/graemlins/patriot.gif" alt="" />
Posted By: TheGoat

Re: i think.. it's the rings... - 11/02/12 08:38 PM

it does rattle, but i installed a new one anyways yesterday. haven't checked it yet. i will keep you guys updated.
Posted By: homerdog

Re: i think.. it's the rings... - 11/05/12 03:07 PM

Quote
it does rattle, but i installed a new one anyways yesterday. haven't checked it yet. i will keep you guys updated.


Make sure the connecting hose isn't plugged either.
© 2021 4x4Wire TrailTalk