4x4Wire TrailTalk

'93 Sidetrack has me sidetracked!!

Posted By: Lha1988

'93 Sidetrack has me sidetracked!! - 01/28/17 05:13 PM

I bough my Wife this Suzuki Sidetrack some years ago. It ran great when bought,then after a year or so,started having trouble. It first blew a fuse,replaced it,stopped again and within a few minutes running time,stopped again. I was told that the problem was the ECM,or computer. I had the unit rebuilt at a shop in Fla,put it in,ran a few minutes,then stopped. I bought a new distributor,nothing. I had it in a prestigious,well equipped shop,three times,had the computer re-rebuilt,it ran almost long enough to make the 6-7 mile trip home. The entire vehicle is in great shape except for one small problem:won't run. I have tried to find out if some type of aftermarket ignition would work,but with no avail. Has anyone heard of an aftermarket distributor that will fit or other model[Samurai,maybe] that would work. I'm even open to adapting a Weber carb to make it work. Help please!!
Posted By: rxinhed

Re: '93 Sidetrack has me sidetracked!! - 01/28/17 07:27 PM

You're positive the issue is ignition? Have you evaluated the timing, cam position sensors, TPS, etc.? Have you looked at the fuel system? Some 90s vehicles were equipped with fuel shutoff valves for the cases of roll-over, hard impacts.

Last, we need some data on your ride: year, model, engine...

Posted By: Lha1988

Re: '93 Sidetrack has me sidetracked!! - 01/29/17 11:21 PM

Positive it's ignition. Fuel would not blow ignition fuse. It is getting fuel and has new[not rebuilt] distributor,coil and all the other ignition parts. ECM has been rebuilt twice,and thousands spent at a fully equipped shop.
Posted By: rxinhed

Re: '93 Sidetrack has me sidetracked!! - 01/30/17 02:59 AM

Still need more data.

Have you gone through wiring? Ground connections? Relays?

Is there something in the fuse block not right?
Posted By: 4x4Wire

Re: '93 Sidetrack has me sidetracked!! - 01/30/17 03:49 PM

Frequently those types of problems are related to grounding issues. Another issue I have experienced is frayed wire in a wiring harness that caused intermittent problems.

Recommend you check ground connections (engine to frame, frame to body, and body to battery).

Next, isolate the specific power source to the fuse. With fuse out, run a jumper wire (with fuse holder) to see if you blow the fuse in the jumper wire.
Posted By: Lha1988

Re: '93 Sidetrack has me sidetracked!! - 01/30/17 04:57 PM

BTDT with cable tracker,multimeter,test light. Replaced all relays,many fuses,which blow before it starts. I could get an aftermarket unit used on track cars with advance,but would cost lots of money. I could probably convert it to carburetor with 4 Mikunis,but with no advance on distributor,it wouldn't run well. I thought about removing the motor for use as a emergency generator,but have my 1941 Ford tractor already setup with 3 point 10 KW generator.
Posted By: 4x4Wire

Re: '93 Sidetrack has me sidetracked!! - 01/30/17 07:10 PM

Fuse block?? Corrosion on the underside???
Posted By: Lha1988

Re: '93 Sidetrack has me sidetracked!! - 01/31/17 03:08 AM

The first thing I did was to clean up the fuseblock and put di-electric grease on the fuses. I also did the same with the relays,about 5-6 of them. I was an Commercial Electrician,but this stuff is much different than I'm used to with the computer controlled motor. My other vehicles don't have them. I've been working on motorcycles and cars,tractors,etc for about 50 years and haven't failed to get one fixed. I guess I'll sell it for junk.
Posted By: Lha1988

Re: '93 Sidetrack has me sidetracked!! - 02/16/17 08:42 PM

Anyone interested in buying this Suzuki for salvage price of about $250.00,it's in good condition other than the problem discussed. The 4 wheel drive works well and the interior and exterior are in great shape. In 38305 area code.
© 2022 4x4Wire TrailTalk